Monday, July 15, 2013

OSPF Broadcast Mode


Pic. 1 - Topology Diagram.

Task 1
Advertise into OSPF area 100 all interfaces that belong to Vlan 100. Advertise Loopback0 addresses of R4, and SW1 into OSPF. Do not use network statement to accomplish that.

Task 2
Enable OSPF area 0 on serial0/0 interface of R3. Use 'network' statement with the most specific wildcard mask.

Task 3
Advertise into OSPF R6's Loopback0 address. It should not appear in any area. Also make sure that no other connected interface will be advertised into OSPF. Save configuration for the next lab.

Questions
Try to answer the following questions:
  1. What type of election occurs in OSPF Broadcast/NMBA modes? What three types of router roles are available in these modes?
  2. What is the purpose of DR and BDR?
  3. How do DR/BDR get elected?
  4. What are the two link-local multicast addresses used by OSPF in Broadcast mode?
  5. Is OSPF Broadcast mode Cisco proprietary or industry standard technique?
  6. What are the types of relationships built between OSPF routers in Broadcast mode?
  7. How can you influence the initial election of DR/BDR?
  8. Are DR/BDR roles pre-emptive?
  9. How can you change the role of the router in Broadcast/NBMA networks without re-loading them?
  10. What is the meaning of OSPF priority 0?
Lab Solution

Solution configuration below:

https://docs.google.com/file/d/0BwE5C95tpjZOdzcyM2RsWDZobzQ/edit?usp=sharing


Task 1
Advertise into OSPF area 100 all interfaces that belong to Vlan 100. Advertise Loopback0 addresses of R4 and SW1 into OSPF. Do not use network statement to accomplish that. 

R3 Config :
! OSPF process 1 has already been enabled in the previous lab
!
interface FastEthernet0/0
 ip ospf 1 area 100
!

R4 Config:
!
router ospf 1
!
interface FastEthernet0/1.100 
 ip ospf 1 area 100

!
interface Loopback0
 ip ospf 1 area 100
!

R6 Config:
!
router ospf 1
!
interface FastEthernet0/0
 ip ospf 1 area 100
!

SW1 Config:
!
! If this was a real multilayer switch you would need to type:

! ip routing
!
router ospf 1
!
interface Vlan 100
 ip ospf 1 area 100
!
interface loopback0
 ip ospf 1 area 100
!

Task 2
Enable OSPF area 0 on serial0/0 interface of R3. Use 'network' statement with the most specific wildcard mask.

R3 Config:
!
router ospf 1
 network 172.16.0.3 0.0.0.0 area 0
!

Task 3
Advertise into OSPF R6's Loopback0 address. It should not appear in any area. Also make sure that no other connected interface will be advertised into OSPF. Save configuration for the next lab.

R6 Config:
!
route-map CONN_TO_OSPF permit 10
 match interface lo0
!
router ospf 1
 redistribute connected route-map CONN_TO_OSPF subnets
!

What You Should See


Pic. 2 - OSPF Neighbors.

Pic. 3 - R3's OSPF Routing Table.

Study Drill
  1. Why is 10.0.6.6 (R6) showing 2-Way state with SW1?
  2. Why did I enable OSPF area 0 on R3 (serial0/0) interface. What would happen if I did not configure OSPF area 0 on R3?
As for the second question, AREA 0 becomes a backbone area in OSPF domain. Without it, only routers within the same area can communicate.

In our example we have four routers in VLAN 100. Since, this is a broadcast network, one router will be elected DR (highest priority, or in case of a tie, the highest router-id), another (second highest priority) will be elected BDR. All other routers in this broadcast domain become DROTHERs. DROTHERs only establish FULL adjacency with DR/BDR. Between themselvers, the state is always 2-way.

Recall that in broadcast and NBMA networks (legacy stuff such as Frame-Relay, ATM, X.25) require the presence of a DR (and possibly BDR). The routers will form FULL state (full LSA exchange) with DR/BDR but not between all other routers (called: DROTHERS). This save a lot of time on necessary and redundant LSA exchanges.

DR election follows this process:
  1. Prefer the router with the highest OSPF priority on an interface (unless DR is already elected).
  2. In case the priority is the same Prefer the router with the highest OSPF ID (unless DR is already elected).
BDR is elected in the same way only second highest parameter wins. 

Notice though that the priority of 0 (zero), makes a router ineligible of becoming DR/BDR. This can help to change the role of a router seemlessly (check the later lab on DR configuration).

Incidentally, the OSPF broadcast mode is Cisco proprietary, implemented by default on broadcast (Ethernet, Token-Ring) and NBMA (except on point-to-point sub-interfaces). Communication between routers ('hello') still uses link-local multicast 224.0.0.5 address. In order to send update to DR (the only authorized source of updates in these networks), the destination address is 224.0.0.6.


GNS topology used in this lab can be downloaded from the blog's main page.